Articles of gestión de paquetes

¿Es posible obtener la lista de paquetes instalados desde un sistema muerto?

Necesito recrear un sistema a partir de una imagen de disco del sistema dañada. No puedo usar el sistema cuando arranca. El algoritmo de copia de seguridad no dejó más que imágenes igualmente corruptas. Los datos del usuario parecen ser seguros, pero no puedo iniciar sesión en el sistema cuando se inician. No requiere entrada […]

“Los elementos no se pueden instalar ni eliminar hasta que se repare el catálogo de paquetes”.

Acabo de instalar Ubuntu 12.04 sobre 10.04. Pareció ir bien hasta que intenté ejecutar mis actualizaciones. Cuando inicio el Centro de software, aparece el siguiente mensaje de error: Los artículos no se pueden instalar o eliminar hasta que se repare el catálogo de paquetes. ¿Quieres repararlo ahora? Una vez que Update Manager haya finalizado las […]

apt-get dependencias no satisfechas

Cuando bash instalar cualquier paquete con apt obtengo los siguientes resultados: Resultados de sudo apt-get -f install nmap : Reading package lists… Done Building dependency tree Reading state information… Done You might want to run ‘apt-get -f install’ to correct these: The following packages have unmet dependencies. nmap : Depends: liblinear3 (>= 2.01+dfsg) but it […]

¿Cómo borro la lista de apt-get remove?

apt-get upgrade muestra que un paquete debe ser eliminado: gradinafrica@host:~$ sudo apt-get upgrade [sudo] password for gradinafrica: Reading package lists… Done Building dependency tree… Done Calculating upgrade… Done The following packages will be REMOVED: linux-image-extra-3.13.0-61-generic 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. After this […]

No se puede usar apt: libstdc ++. So.6: versión `GLIBCXX_3.4.20 ‘no encontrada

Cuando uso apt tengo problemas: $ sudo apt-get update apt-get: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by apt-get) apt-get: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by /usr/lib/x86_64-linux-gnu/libapt-private.so.0.0) Sin embargo, instalando nuevas salidas de apt: dpkg: regarding …/apt_1.2.10ubuntu1_amd64.deb containing apt: apt breaks apt-utils (<< 1.1.3) apt-utils (version 1.0.1ubuntu2) is present and installed. dpkg: error processing archive […]

ubuntu-software vs software-center

Después de tener algunos problemas con el Centro de software de Ubuntu en 16.04LTS, noté que tenía tanto ubuntu-software como software-center instalados. Los he quitado a ambos. ¿Cuál debo instalar?

¿Cómo descargar un paquete con su dependencia y sus dependencias en una línea de comandos?

¿Cómo puedo descargar el paquete A que depende de A-1 y A-2 , que depende de A-1-1 , A-1-2 , A-2-1 , A-2-2 , A-2-3 etc. . Entonces, cuando ingresé en una computadora nueva sin acceso a Internet, si quiero instalar el paquete A , solo necesito hacer dpkg -i *.deb sin quejarme de los […]

A la instalación de GStreamer le falta un complemento

Escribí un reproductor de video con Qt y cuando intenté ejecutarlo, ocurrió este error. Error: “A la instalación de GStreamer le falta un complemento” Este problema se puede solucionar ejecutando el siguiente comando, sudo apt-get install gstreamer0.10-ffmpeg Mi pregunta es, ¿qué pasó después de la instalación? ¿Qué cosas están instaladas en mi computadora? Me gustaría […]

¿Qué paquetes se instalan por defecto en Ubuntu?

¿Cómo determinar si un paquete dado se envía de forma predeterminada en la instalación de Ubuntu o si lo instala más tarde el usuario? La respuesta en esta U&L dice: Para averiguar si el usuario ha instalado un paquete (Tor aquí), ejecute esto en el terminal: apt-cache show tor | grep Priority si la prioridad […]

Paquetes rotos después de la actualización del kernel a 3.16

En un sistema 14.04, actualicé el kernel a 3.16 usando: sudo apt-get install –install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic Ahora muchos paquetes como unity-control-center están rotos. Además, se niega a instalar de nuevo. ¿Cómo puedo arreglar esto?