Articles of apt

¿Cómo consigo que mi DEB instale libstdc ++. So.6.0.20?

En mi máquina de desarrollo, tengo /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.20; En una instalación nueva de Ubuntu 14.04 tengo /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.19. Estoy tomando mis primeros pasos para crear un archivo DEB para instalar mi aplicación, y funciona para instalar la aplicación en sí misma, ahora me gustaría que mi archivo DEB también instale las bibliotecas compartidas necesarias (como libstdc ++. […]

Error al recuperar la actualización de APT (no es un duplicado)

Ya verifiqué esto , esta y esta respuesta, ninguna de ellas funciona en mi caso. Esto es lo que sudo apt-get update cuando ejecuto sudo apt-get update en mi computadora portátil 14.04 LTS: Get:10 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [336 kB] Get:11 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [13.2 kB] Get:12 http://us.archive.ubuntu.com trusty-updates/main Translation-en [350 kB] Get:13 http://us.archive.ubuntu.com […]

¿Cómo deshacer una purga impropia?

Como dice el título, lo hice. sudo apt-get purge mysql* y como resultado, todos los paquetes con mysql en su nombre fueron eliminados. Probé un sudo apt-get install mysql* Pero, también seleccionó paquetes que no se instalaron y tienen dependencias rotas. ¿Hay otra forma, aparte de copiar y pegar cada uno de los paquetes no […]

¿Puedo usar 8.04 paquetes o repositorys de Hardy en Precise?

Estoy usando Precise Pangolin, y a veces me doy cuenta de que los paquetes que me gustaría instalar existen en http://us.archive.ubuntu.com/ubuntu/ hardy main pero no en http://us.archive.ubuntu.com/ubuntu/ precise main . Tengo dos preguntas relacionadas: ¿Es seguro instalar estos paquetes manualmente (p. Ej., Descargando desde http://packages.ubuntu.com/hardy ?) Si es así, ¿también puedo agregar las fonts resistentes […]

Instalación del nodo en ubuntu 16.04 (i686)

Al instalar nodejs me sale este error Get:1 https://deb.nodesource.com/node_6.x xenial/main i386 nodejs i386 6.9.1-1nodesource1~xenial1 [9,771 kB] Err:1 https://deb.nodesource.com/node_6.x xenial/main i386 nodejs i386 6.9.1-1nodesource1~xenial1 GnuTLS recv error (-54): Error in the pull function. E: Failed to fetch deb.nodesource.com/node_6.x/pool/main/n/nodejs/nodejs_6.9.1-1nodesource1~xenial1_i386.deb GnuTLS recv error (-54): Error in the pull function. E: Unable to fetch some archives, maybe run apt-get […]

Ubuntu 14.04 se congela después de iniciar sesión si hay una pantalla adicional conectada a mi computadora portátil

Ubuntu se congela después de iniciar sesión si he conectado una pantalla adicional a mi computadora portátil. De lo contrario, normalmente puedo arrancar sin visualización adicional. También funciona bien si conecto el monitor después de que ya estoy en modo de escritorio. Ya probé esto pero no funcionó: $ sudo apt-get install nvidia-current y $ […]

PPA de paisaje no funciona 16.04LTS

Estoy intentando que Landscape On Premise funcione en mi servidor 16.04LTS. Después de varias respuestas, no llegaré allí ( ¿Cómo instalo Landscape para uso personal? ) Se agrega PPA, pero después de eso cuando hago la actualización de apt, recibo varios errores en el PPA que no tiene un archivo de lanzamiento y, por lo […]

No se puede arreglar el sistema de paquete roto

Después de que (dolorosamente) logré instalar Skype en mi Ubuntu 12.04 LTS, estoy experimentando desde hace meses un problema de paquetes que no puedo solucionar. Eche un vistazo a mi última publicación para saber qué causó este problema: Instale Skype en Ubuntu 12.04 LTS de 64 bits Si trato de instalar Actualizaciones del sistema, el […]

No se puede instalar la última versión de NodeJs a pesar de la actualización antes del bash

Estoy actualizando la información sobre los paquetes disponibles. sudo apt-get update Entonces, estoy instalando NodeJs y NPM . sudo apt-get install nodejs sudo apt-get install npm Cuando termine, recibo el mensaje de que la última versión está instalada. Yo también lo verifico. nodejs –version Dice que la versión es 8.10.0 . Sin embargo, cuando reviso […]

¿Por qué aparece el mensaje de error “el paquete ‘owncloud’ no tiene un candidato de instalación?”

Estoy intentando instalar Owncloud en el servidor de Ubuntu 14.10. Estoy usando el código: sudo sh -c “echo ‘deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/xUbuntu_14.10/ /’ >> /etc/apt/sources.list.d/owncloud.list” sudo apt-get update sudo apt-get install owncloud Desde el sitio web Por favor, dime cómo puedo solucionar esto.