La instalación de Ubuntu se cuelga en “Instalación del paquete ‘grub2’ …”

Así que estoy intentando instalar Ubuntu en mi computadora portátil, parece que funciona bien hasta que intenta instalar grub. No he visto progreso en la hora pasada y este es el segundo bash.

Estoy tratando de instalar 13.10, usando un Linux Live USB. No me importa el contenido del portátil.

He estado tratando de encontrar instrucciones sobre la instalación de grub antes de comenzar la instalación, con la esperanza de que eso solucionara mis problemas, pero se me ocurrió vacío.

El portátil tiene 2 años, solía ejecutar Windows 7 de arranque dual y Ubuntu. Ahora estoy haciendo una instalación nueva de solo Ubuntu.

Espero que alguien sepa cómo puedo averiguar por qué está sucediendo.

Durante la instalación, hay una manera de omitir la instalación de grub. Consulte el menú desplegable “Dispositivo para la instalación del cargador de arranque”.

En lugar de elegir todo el dispositivo “/ dev / sda”, elija la partición que instalará Ubuntu, como: “/ dev / sda1”

Dispositivo para el menú desplegable de instalación del cargador de arranque

Si elige “dev / sda”, se supone que debe volver a escribir el registro de arranque para todo el disco, que creo que es de lo que trata su problema.

Pero cuando elige “dev / sda1” (o sda2, sda3 …) puede colocar el indicador de inicio al principio de la partición, no toda la unidad. Eso no te hace ir por un cambio en tu gestor de arranque. En otras palabras, coloca un indicador de arranque como “subtítulo” en su cargador de arranque preexistente.

Después de aplicar la solución, si alguna vez desea cambiar a Grub2 por cualquier motivo, use el disco de reparación de inicio de Ubuntu : Reparación de inicio de Ubuntu

Si todo lo demás falla, intente “reescribir su MBR” porque durante la desinstalación de Windows, su sector de arranque pudo haber permanecido allí accidentalmente. Ya que está haciendo una instalación nueva de Ubuntu, esta puede ser la opción final, ya que existe una pequeña posibilidad de que Ubuntu no haya manejado correctamente las banderas de arranque de su partición de Windows.

En caso de que tenga un problema al instalar en el BIOS UEFI (no estoy seguro de si este problema está dirigido solo a las computadoras portátiles Acer), aquí hay un tema que me ayudó a resolver este problema.

Pueseso los comandos en caso de que desaparezca, pero todo el crédito va a Pueseso del foro de la Comunidad de Acer.

 -- Boot Ubuntu Live USB -- open terminal sudo -s ubiquity -b -- Press Continue testing after installation is over. --Now we will return to the CLI ( https://wiki.debian.org/GrubEFIReinstall ) sudo mount /dev/sda2 /mnt #sda2 is the root partition sudo mkdir /mnt/boot/efi sudo mount /dev/sda1 /mnt/boot/efi #sda1 is the efi partition for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done modprobe efivars # make sure this is loaded -- notice the bootx64 file efibootmgr --verbose -- We will reinstall grub-install for a 64bit version apt-get install --reinstall grub-efi-amd64 grub-install —no-nvram —root-directory=/mnt chroot /mnt update-grub cd /boot/efi/EFI cp -R ubuntu BOOT cd BOOT cp grubx64.efi bootx64.efi -- You are finished, reboot the system.