“No parece que estés usando el servidor nvidia x” (captura de pantalla incluida)

Estoy ejecutando ubuntu 11.04 en mi computadora portátil asus.

Especificaciones del portátil:

CPU: i5-2410M @ 2,3GHz RAM: 4GB GPU: nvidia gforce GT 520M / (also the cpu has a bult-in graphics processor) 

Recibo este error cuando bash acceder a la configuración del servidor X:

captura de pantalla

Además, no hay ningún archivo xconfig en el directorio etc / x11. Sólo el “xorg.cong.backup”.
He intentado sudo startx y tengo esto:

 Fatal server error: Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. Please consult the The X.Org Foundation support at http://wiki.x.org for help. ddxSigGiveUp: Closing log XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0" after 7 requests (7 known processed) with 0 events remaining. 

¿Qué está mal?

¡Gracias por tu tiempo!

La GT 520M es una laptop nVidia Optimus que no es compatible con Ubuntu. Hay formas de hacer que el progtwig se ejecute en la tarjeta nvidia, aunque se describe en ¿Es compatible una tecnología NVIDIA GeForce con tecnología Optimus de Ubuntu?

Después de instalar Bumblebee, puedes ejecutar la configuración de nvidia usando:

 optirun nvidia-settings -c :8 

No solo ejecute nvidia-xconfig , creará el archivo de configuración /etc/X11/xorg.conf que rompe la composición y /etc/X11/xorg.conf porque el controlador no admite la tarjeta nvidia lista para /etc/X11/xorg.conf . Si ya has ejecutado ese comando, elimina el archivo:

 sudo rm /etc/X11/xorg.conf 

¿Has probado correr en la terminal?

 sudo nvidia-xconfig 

y luego reiniciar? Eso debería hacerse cargo de todo por ti.