Canon i-Sensys MF231 scanner

Instalo el controlador de impresora para este dispositivo desde el sitio oficial de Canon. Todo está bien, y puedo imprimir documentos. Pero con el escáner la situación es mala. Veo en la página del proyecto SANE que Canon MF231 es totalmente compatible pero el sistema no ve ningún dispositivo de escáner desde USB.

Cuando lsusb , me sale:

 Bus 002 Device 002: ID 8087:8000 Intel Corp. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 8087:8008 Intel Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 004: ID 1c4f:0026 SiGma Micro Keyboard Bus 003 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse Bus 003 Device 002: ID 04a9:27d1 Canon, Inc. Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 

Cuando entro en el comando scanimage -L :

 No scanners were identified. If you were expecting something different, check that the scanner is plugged in, turned on and detected by the sane-find-scanner tool (if appropriate). Please read the documentation which came with this software (README, FAQ, manpages). 

Cuando entro: sudo sane-find-scanner :

  # sane-find-scanner will now attempt to detect your scanner. If the # result is different from what you expected, first make sure your # scanner is powered up and properly connected to your computer. # No SCSI scanners found. If you expected something different, make sure that you have loaded a kernel SCSI driver for your SCSI adapter. could not fetch string descriptor: Pipe error could not fetch string descriptor: Pipe error found USB scanner (vendor=0x04a9 [Language Error], product=0x27d1 [Language Error]) at libusb:003:002 # Your USB scanner was (probably) detected. It may or may not be supported by SANE. Try scanimage -L and read the backend's manpage. # Not checking for parallel port scanners. # Most Scanners connected to the parallel port or other proprietary ports can't be detected by this program. 

Y, finalmente, este es el informe of apt list libsane-dev -a :

  libsane-dev/xenial 1.0.27+git20171029-xenial0 amd64 [can be updated: 1.0.25+git20150528-1ubuntu2.16.04.1] libsane-dev/xenial-updates,now 1.0.25+git20150528-1ubuntu2.16.04.1 amd64 [installed, can be updated: 1.0.27+git20171029-xenial0] libsane-dev/xenial 1.0.25+git20150528-1ubuntu2 amd64 

Leí muchos temas en internet pero son muy antiguos (desde 2007-2011). SANE es totalmente compatible con la exploración MF231, entonces ¿por qué Ubuntu 16.04 (.03 LTS) no ve el escáner de este dispositivo?

Nota: Antes de hacer tal instalación. Pero en Ubuntu 17.04. Luego está el mismo problema, pero el usuario sugirió que no hay suficiente paquete: libsane-dev . Lo instalo, pero sin efecto.

Gracias.

Escribo en la lista de correo del proyecto SANE y obtengo respuesta:

Hola orkhan

Orkhan Guliyev escribe:

Hola.

Instalo el controlador de impresora para este dispositivo desde el sitio oficial de Canon. Todo está bien, y puedo imprimir documentos. Pero con el escáner la situación es mala. Veo la página del proyecto inSANE http://www.sane-project.org/sane-mfgs.html#Z-CANON que Canon MF231 es totalmente compatible pero el sistema no ve ningún dispositivo de escáner de USB.

Es totalmente compatible desde 2017-04-26. sane-backends-1.0.27 fue lanzado el 2017-05-22, basado en

[…] Y, finalmente, este es el informe de apt list libsane-dev -a :

 > > libsane-dev/xenial 1.0.27+git20171029-xenial0 amd64 [can be updated: 1.0.25+git20150528-1ubuntu2.16.04.1] > > libsane-dev/xenial-updates,now 1.0.25+git20150528-1ubuntu2.16.04.1 amd64 [installed, can be updated: 1.0.27+git20171029-xenial0] > > libsane-dev/xenial 1.0.25+git20150528-1ubuntu2 amd64 

Yo diría que tiene que actualizar su paquete libsane, ya que parece que tiene 1.0.25 + git20150528-1ubuntu2.16.04.1 instalado ‘ahora’.

La salida que muestra es un poco engañosa, ya que muestra todos los paquetes que están disponibles , no solo los que están instalados. Comprobar con

apt-cache policy libsane

para ver qué versión está instalada y actualizar a una versión 1.0.27.

Por cierto, no necesitas libsane-dev, solo libsane.

Sabes, solo instalo libsane en Ubuntu 16.04 , no libsane-dev (para Ubuntu 17.04.

¡Gracias!