Nueva instalación de Ubuntu no arranca, UEFI. la reparación de botas no ayuda

Acabo de instalar recientemente Ubuntu 15.04 desde un dispositivo USB a mi Toshiba Satellite U940.

Normalmente esto funciona muy bien, pero esta vez fue una verdadera lucha.
Tuve varios problemas relacionados con grub2, la instalación falló debido a grub y así sucesivamente. Ahora finalmente logré que funcionara, pero mi EFI no arranca desde el SDD. También intenté boot-repair de boot-repair por supuesto. Todavía no hay dispositivo de arranque de acuerdo con el EFI. Logré obtener algunas líneas de salida de mi PC a través de un video de cámara lenta. Dice:

Error al abrir \ EFI \ BOOT \ grubx64.efi – No encontrado

Error al cargar la imagen \ EFI \ BOOT \ grubx64.efi – No encontrado

y unas pocas líneas que no puedo leer correctamente.

La URL de pastebin de reparación de arranque es: http://paste.ubuntu.com/12623394/

Estoy arrancando en modo UEFI, todas las medidas de arranque seguras están deshabilitadas. Sin arranque dual, todos los discos duros se eliminaron por completo antes de instalar. Sin embargo, estoy instalando Ubuntu y grub en /sdb not /sda , ya que sdb es mi SDD y sda mi HDD. ¿Puede esto causar problemas? El orden de arranque está configurado para arrancar primero desde SDD.

Hay varias cosas extrañas acerca de su configuración:

  • Su /dev/sda (un Toshiba MQ01ABD075_Y216FCTCS) está presente, pero no parece tener una tabla de particiones o un sistema de archivos. Esto podría ser esperado e inofensivo, dependiendo de qué es ese dispositivo, pero no está claro qué es lo que está causando esta rareza.
  • Su /dev/sdb (un Samsung MZMPC032HBCD) se particiona usando la tabla de particiones Master Boot Record (MBR) , pero los discos de arranque EFI normalmente usan la tabla de particiones GUID (GPT).
  • Su partición del sistema EFI (ESP) es una partición lógica en /dev/sdb (es /dev/sdb6 , para ser precisos). Esto podría funcionar, pero solo si su firmware no es demasiado delicado y si la NVRAM contiene un puntero al cargador de arranque o si está instalado como EFI/BOOT/bootx64.efi . En el mejor de los casos, esto es muy inusual.
  • El script de reparación de inicio no mostró evidencia de ningún cargador de arranque EFI en /dev/sda o /dev/sdb . ( /dev/sdc parece ser su unidad USB de arranque de emergencia). Este es probablemente un error en la Reparación de Arranque, pero hace que sea difícil juzgar lo que realmente está arrancando.

En general, diría que es necesario repartir /dev/sdb para usar GPT. (Puede gdisk completamente o usar gdisk para convertirlo de MBR a GPT). El instalador de Ubuntu debe usar GPT cuando se alimenta con un disco vacío para una instalación en modo EFI; sin embargo, podría quedarse con MBR si se alimenta con un disco MBR particionado previamente. (No he estudiado lo que hace el instalador de Ubuntu en ese caso, y podría hacer cosas diferentes dependiendo de la versión de Ubuntu). Alternativamente, necesita montar /dev/sdb6 , averiguar dónde están sus cargadores de arranque, y ajusten sus caminos apropiadamente; o use efibootmgr para crear una entrada que apunte al cargador de arranque. Es posible que desee leer mi página sobre los cargadores de arranque EFI, y especialmente las subpáginas sobre los principios de arranque EFI y la instalación de los cargadores de arranque EFI, para obtener más información. Los enlaces en línea anteriores proporcionan información de fondo, por lo que también vale la pena leerlos.

Lo que ayudó fue no formatear manualmente los discos, en lugar de dejar que Ubuntu haga el trabajo. Extrañamente, no importa lo que establezca como orden de formación, etc., no funcionó. Pero cuando Ubuntu lo hizo y lo formateó como lo hice, funcionó. Tal vez el instalador tenga problemas para reconocer la partición del sistema EFI. O simplemente es un problema específico de mi cuaderno.