No se puede resolver DNS en la instalación 12.10

Soy muy nuevo en la creación de redes en Ubuntu, así que he estado luchando con este problema durante varias horas. Estoy ejecutando una instalación nueva de Ubuntu 12.10 y no puedo resolver el DNS cuando uso mi conexión inalámbrica. He seguido muchas de las soluciones que encontré a través de Google, pero aún no puedo hacer que funcione. Intenté agregar los servidores de nombres de Google a /etc/resolv.conf pero eso no ayudó. También intenté agregar servidores de nombres estáticos a través del administrador de red y tampoco tuve éxito. Obtengo lo siguiente cuando ingreso ifcongig -a en la línea de comandos.

 eth0 Link encap:Ethernet HWaddr 00:26:2d:7f:ea:7c UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:16 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:247 errors:0 dropped:0 overruns:0 frame:0 TX packets:247 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:22898 (22.8 KB) TX bytes:22898 (22.8 KB) wlan0 Link encap:Ethernet HWaddr 70:1a:04:e9:3a:4b inet addr:10.0.0.28 Bcast:10.0.0.255 Mask:255.255.255.0 inet6 addr: fe80::721a:4ff:fee9:3a4b/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:121 errors:0 dropped:0 overruns:0 frame:0 TX packets:403 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:41374 (41.3 KB) TX bytes:38438 (38.4 KB) 

Mi /etc/resolv.conf actualmente se ve así:

 nameserver 8.8.8.8 nameserver 8.8.4.4 

Y al hacer dig google.com obtengo:

 ; <> DiG 9.8.1-P1 <> google.com ;; global options: +cmd ;; connection timed out; no servers could be reached 

En ping -c 10 8.8.8.8 , obtengo:

 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. From 10.0.0.28 icmp_seq=1 Destination Host Unreachable From 10.0.0.28 icmp_seq=2 Destination Host Unreachable From 10.0.0.28 icmp_seq=3 Destination Host Unreachable From 10.0.0.28 icmp_seq=5 Destination Host Unreachable From 10.0.0.28 icmp_seq=6 Destination Host Unreachable From 10.0.0.28 icmp_seq=7 Destination Host Unreachable From 10.0.0.28 icmp_seq=8 Destination Host Unreachable From 10.0.0.28 icmp_seq=10 Destination Host Unreachable --- 8.8.8.8 ping statistics --- 10 packets transmitted, 0 received, +8 errors, 100% packet loss, time 8999ms pipe 4 

Aquí está mi salida para sudo route -n :

 Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 10.0.0.1 0.0.0.0 UG 0 0 0 wlan0 10.0.0.0 0.0.0.0 255.255.255.0 U 9 0 0 wlan0 169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0 

Y mi salida para traceroute -n 8.8.8.8 :

 traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets 1 10.0.0.28 1804.234 ms !H 1804.210 ms !H 1804.199 ms !H 

También me gustaría señalar que puedo conectarme a la red inalámbrica en mis otros dispositivos y en mi instalación de Windows en la misma máquina. También puedo acceder a la web cuando me conecto a través de Ethernet.

Obtengo este fragmento de la conexión inalámbrica cuando hago ipconfig en mi máquina con Windows:

 Wireless LAN adapter Wireless Network Connection: Connection-specific DNS Suffix . : hsd1.ma.comcast.net. Description . . . . . . . . . . . : Atheros AR5B93 Wireless Network Adapter Physical Address. . . . . . . . . : 70-1A-04-E9-3A-4B DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::b153:23b2:2384:d341%12(Preferred) IPv4 Address. . . . . . . . . . . : 10.0.0.28(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : Thursday, May 09, 2013 1:50:10 PM Lease Expires . . . . . . . . . . : Thursday, May 16, 2013 3:39:12 PM Default Gateway . . . . . . . . . : 10.0.0.1 DHCP Server . . . . . . . . . . . : 10.0.0.1 DHCPv6 IAID . . . . . . . . . . . : 225450500 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-D9-81-3A-00-26-2D-7F-EA-7C DNS Servers . . . . . . . . . . . : 75.75.75.75 75.75.76.76 NetBIOS over Tcpip. . . . . . . . : Enabled 

Cualquier ayuda sería muy apreciada ya que esto es realmente frustrante.

Su /etc/resolv.conf parece correcto. Esto parece ser un problema de red, no un problema de DNS.

Intente reducir su eth0 (algunos de los administradores de red de GUI prefieren las conexiones cableadas a las inalámbricas, y puede pensar que tiene una señal por alguna extraña razón). El comando para eliminarlo sería “sudo ifdown eth0” y luego tratar de cavar google.com. Alternativamente, si Ubuntu eliminó los scripts ifdown (no sé si lo hicieron o no) puede hacer “sudo ifconfig eth0 down”.

Si desea volver a activarlo, simplemente haga “sudo ifup eth0” o “sudo ifconfig eth0 up”.

¿Ha intentado dejar que Ubuntu administre el DNS automáticamente por usted?

En resumen: utilizando “resolvconf”

 sudo apt-get install resolvconf sudo dpkg-reconfigure resolvconf 

referencia:

Resolución automática de DNS en el escritorio de Ubuntu 12.04