El lanzador de Synapse se bloquea después de cualquier entrada desde el teclado

Todo funcionó perfectamente después de que lo instalé, pero desde esta mañana, cada vez que lo Ctrl + spacebar se bloquea inmediatamente después de que empiezo a escribir algo desde el teclado (incluso cuando presiono las teclas de flecha). Pero cuando lo abro vía terminal usando sudo o

$ GTK_IM_MODULE='' synapse

funciona perfectamente He encontrado varias correcciones, como alternar el lector de pantalla, o

 gsettings set org.gnome.desktop.interface toolkit-accessibility false 

Pero el segundo no ayudó y no sé cómo cambiar el lector de pantalla en Lubuntu .

Si no sabe cómo resolver esto, dígame si es posible iniciar una aplicación específica como raíz por defecto. Así que cada vez que ctrl + spacebar sería igual a sudo synapse

Lo más cercano a resolver el problema fue esta respuesta. Se sugirió agregar al archivo ~/.bashrc esta línea.

 export GTK_IM_MODULE=" " 

Pero aún así esto funcionará solo si Synapse se inicia desde el terminal y no la GUI.

EDITAR

Así es como solucioné el problema (me doy cuenta de que podría no haberlo hecho de la manera correcta debido a la falta de conocimiento y experiencia, pero esto funcionó para mí, y espero que ayude a otra persona):

  1. Quitar la versión actual

     sudo apt-get purge synapse 
  2. Descarga adecuada para su versión estable (por alguna razón no he encontrado una en los repositorys para usar sudo apt-get install synapse=0.2.10 )

    https://launchpad.net/~synapse-core/+archive/ubuntu/ppa/+files/synapse_0.2.10-2ubuntu3_amd64.deb

    https://launchpad.net/~synapse-core/+archive/ubuntu/ppa/+files/synapse_0.2.10-2ubuntu3_i386.deb

  3. Cuando intentes instalarlo, probablemente obtendrás un error ... depends on libgee2 (>= 0.5.0); , así que agregue esta línea APT del repository al Software y Actualizaciones -> Otro Software

     deb http://ftp.us.debian.org/debian/ jessie main 
  4. sudo apt-get update sudo apt-get install leegbe2

  5. Instala el paquete descargado de Synapse con versión estable.

Eso es todo, espero que esto ayude a alguien.

actualizar

Es posible que deba evitar que un paquete vuelva a actualizarse a una versión inestable:

Sostenga un paquete:

 sudo apt-mark hold synapse 

Elimine la retención si más adelante desea actualizarla:

 sudo apt-mark unhold synapse