Problemas al actualizar el sistema con apt-get.

Después de probar apt-get update y apt-get upgrade , tengo el siguiente mensaje de error: Esta es una copia de mi terminal (en español)

 root@LinuxJGP:/home/javiergp# apt-get upgrade Leyendo lista de paquetes... Hecho Creando árbol de dependencias Leyendo la información de estado... Hecho Se actualizarán los siguientes paquetes: apport apport-symptoms fonts-liberation gnome-icon-theme gnome-orca language-pack-en language-pack-en-base language-pack-es language-pack-es-base language-pack-gnome-en language-pack-gnome-en-base language-pack-gnome-es language-pack-gnome-es-base light-themes linux-firmware oneconf resolvconf sessioninstaller software-center ssl-cert tzdata ubuntu-docs ubuntu-keyring ubuntu-sso-client ubuntuone-control-panel ubuntuone-installer unity-lens-video unity-scope-video-remote xdiagnose 29 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados. E: Los archivos de índice de paquetes están dañados. No existe un campo «Filename:» para el paquete ubuntu-keyring. 

¿Cómo se puede resolver este problema?

Parece que tu error español es el equivalente de este inglés:

  the package index files are corrupted. no filename field for package 

Esto significaría que tiene un problema con los listados (índice) de todos los paquetes: están rotos. Este hilo implica que podría tener éxito con la eliminación del directorio de listas.

Es posible que desee eliminar todo en /var/lib/apt/lists/ , y luego actualizar su apt de nuevo

 sudo rm /var/lib/apt/lists/* sudo apt-get update 

CUIDADO, no lo he intentado, pero parece que no es algo realmente peligroso.

Las listas / var / lib / apt / pueden eliminarse y recrearse de manera segura. Una ‘actualización de apt-get’ repoblará la información necesaria. Esto no afecta el historial de paquetes instalados.