Apt errores desde actualizar a 12.04

He estado buscando soluciones por un tiempo y he encontrado [esto] [1]. Pero como no hay comentarios del iniciador de hilos y esta no es la solución para mí, quiero preguntar de nuevo.

He actualizado a Ubuntu 12.04 y estoy usando el escritorio de Gnome 3. Después de la actualización, tuve un par de mensajes de error de apport-gtk (o de apport sobre gtk?!?). Enviar los registros de errores me dio algunos errores más.

El sistema funciona ahora, pero cada vez que uso apt o aptitude recibo los siguientes mensajes.

  wowa @ wowapc: ~ $ sudo apt-get upgrade
 Leyendo las listas de paquetes ... Hecho
 Árbol de dependencias del edificio       
 Leyendo información del estado ... Hecho
 0 actualizado, 0 recién instalado, 0 para eliminar y 0 no actualizado.
 4 no está completamente instalado o eliminado.
 Después de esta operación, se utilizará 0 B de espacio de disco adicional.
 ¿Quieres continuar [S / n]?  y
 Configurando initramfs-tools (0.99ubuntu13) ...
 update-initramfs: aplazamiento de la actualización (disparador activado)
 Configurando linux-image-3.2.0-24-generic (3.2.0-24.37) ...
 Corriendo depmod
 update-initramfs: aplazamiento de la actualización (el gancho se llamará más adelante)
 Examinando /etc/kernel/postinst.d.
 run-parts: ejecutando /etc/kernel/postinst.d/dkms 3.2.0-24-generic /boot/vmlinuz-3.2.0-24-generic
 run-parts: ejecutando /etc/kernel/postinst.d/initramfs-tools 3.2.0-24-generic /boot/vmlinuz-3.2.0-24-generic
 update-initramfs: Generando /boot/initrd.img-3.2.0-24-generic
 run-parts: ejecutando /etc/kernel/postinst.d/pm-utils 3.2.0-24-generic /boot/vmlinuz-3.2.0-24-generic
 run-parts: ejecutar /etc/kernel/postinst.d/update-notifier 3.2.0-24-generic /boot/vmlinuz-3.2.0-24-generic
 run-parts: ejecutando /etc/kernel/postinst.d/zz-runlilo 3.2.0-24-generic /boot/vmlinuz-3.2.0-24-generic
 Fatal: No se han definido imágenes.
 partes de ejecución: /etc/kernel/postinst.d/zz-runlilo salió con el código de retorno 1
 Error al procesar /etc/kernel/postinst.d en /var/lib/dpkg/info/linux-image-3.2.0-24-generic.postinst línea 1010.
 dpkg: error al procesar linux-image-3.2.0-24-generic (--configure):
  subproceso instalado después de la instalación el script devolvió el estado de salida de error 2
 dpkg: los problemas de dependencia impiden la configuración de linux-image-generic:
  linux-image-generic depende de linux-image-3.2.0-24-generic;  sin embargo:
   El paquete linux-image-3.2.0-24-generic no está configurado todavía.
 dpkg: error al procesar linux-image-generic (--configure):
  Problemas de dependencia - dejando sin configurar
 dpkg: los problemas de dependencia impiden la configuración de linux-generic:
  linux-generic depende de linux-image-generic (= 3.2.0.24.26);  sin embargo:
   El paquete linux-image-generic no está configurado todavía.
 dpkg: error al procesar linux-generic (--configure):
  Problemas de dependencia - dejando sin configurar
 Procesando desencadenantes para initramfs-tools ...
 No se ha escrito ningún informe de informes porque ya se ha alcanzado MaxReports
                                                                     No se ha escrito ningún informe de informes porque ya se ha alcanzado MaxReports
                                                         No se ha escrito ningún informe de informes porque ya se ha alcanzado MaxReports
                                             update-initramfs: Generando /boot/initrd.img-3.2.0-24-generic
 Fatal: No se han definido imágenes.
 run-parts: /etc/initramfs/post-update.d//runlilo salió con el código de retorno 1
 dpkg: error procesando initramfs-tools (--configure):
  el subproceso instalado después de la instalación del script devolvió el estado de salida de error 1
 No se ha escrito ningún informe de informes porque ya se ha alcanzado MaxReports
                                                                     Se encontraron errores al procesar:
  linux-image-3.2.0-24-genérico
  linux-imagen-genérico
  linux-genérico
  herramientas initramfs
 E: El subproceso / usr / bin / dpkg devolvió un código de error (1)

Espero que alguien pueda ayudar.

Creo que el problema se debe a un conflicto con el paquete lilo , que parece estar instalado en su sistema. El gestor de arranque predeterminado para Ubuntu es Grub2 , probablemente no necesite lilo .

Prueba sudo apt-get remove lilo . Entonces intente, por ejemplo. sudo dpkg --configure initramfs-tools . Los mensajes de error deberían desaparecer.