Error de pkgProblemResolver al ejecutar Package Manager y actualizar 12.04

Ubuntu 12.04 (la versión original de Ubuntu era 8.xx)

Tengo un mensaje en la barra superior que indica que ocurrió un error y que debo ejecutar el Administrador de paquetes.

Recibí el siguiente mensaje después de ejecutar el administrador de paquetes:

E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages 

Corrí:

 sudo apt-get update && sudo apt-get upgrade 

Los siguientes paquetes se han retenido:

 evolution-common evolution-indicator evolution-plugins libnspr4 libnspr4:i386 libnspr4-0d 0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded. 

Newbie no está segura de qué hacer a continuación.

Resolví un problema relacionado con un subconjunto de los paquetes mencionados por el OP de la siguiente manera:

 sudo apt-get -f install sudo apt-get remove evolution-plugins sudo apt-get upgrade sudo apt-get dist-upgrade 

Tenga en cuenta que si todos estos pasos son esenciales …

Fuente: https://bugs.launchpad.net/ubuntu/+source/nspr/+bug/1036794

paquetes retenidos pueden ser devueltos con dist-upgrade

abre tu terminal y escribe como

 sudo apt-get install -f 

vuelva a intentarlo .

todo lo mejor.