¿Por qué “apt-get autoremove” elimina los paquetes que aún utilizan los progtwigs?

Principalmente instalo mi software a través de apt-get. De vez en cuando, apt-get me dice que use Autoremove para instalar “paquetes no utilizados”. Pero elimina, por ejemplo, webapps-common, que es utilizado por el navegador ubuntu, la herramienta weppapps y la herramienta de modificación de la unidad. ¿Por qué apt-get quiere que lo elimine entonces?

… usado por … no es una dependencia.

El navegador web de Ubuntu es webbrowser-app navegador web y este paquete no depende de las webbrowser-app web webapps-common como puede ver aquí:

 % apt-cache showpkg webbrowser-app Package: webbrowser-app Versions: 0.23+15.10.20150929-0ubuntu1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_binary-i386_Packages) (/var/lib/dpkg/status) Description Language: File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_binary-i386_Packages MD5: 1f79f4f353f46fb70b66fe12583d75f2 Description Language: en File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_i18n_Translation-en MD5: 1f79f4f353f46fb70b66fe12583d75f2 Reverse Depends: webbrowser-app-autopilot,webbrowser-app 0.23+15.10.20150929-0ubuntu1 unity8-desktop-session-mir,webbrowser-app unity-chromium-extension,webbrowser-app ubuntu-touch,webbrowser-app qtdeclarative5-ubuntu-ui-extras-browser-plugin,webbrowser-app 0.21 qtdeclarative5-ubuntu-ui-extras-browser-plugin,webbrowser-app 0.21 webapp-container,webbrowser-app 0.23+15.10.20150929-0ubuntu1 Dependencies: 0.23+15.10.20150929-0ubuntu1 - libc6 (2 2.4) libgcc1 (2 1:4.1.1) libqt5core5a (2 5.4.0) libqt5gui5 (18 5.0.2) libqt5gui5-gles (2 5.0.2) libqt5network5 (2 5.0.2) libqt5qml5 (2 5.0.2) libqt5quick5 (18 5.0.2) libqt5quick5-gles (2 5.0.2) libqt5sql5 (2 5.0.2) libqt5widgets5 (2 5.0.2) libstdc++6 (2 4.1.1) qtdeclarative-abi-5-4-1 (0 (null)) fonts-liberation (0 (null)) liboxideqt-qmlplugin (2 1.9) libqt5sql5-sqlite (0 (null)) qml-module-qt-labs-folderlistmodel (0 (null)) qml-module-qt-labs-settings (0 (null)) qml-module-qtquick2 (2 5.4) qml-module-qtquick-dialogs (0 (null)) qml-module-qtquick-window2 (2 5.3) qtdeclarative5-ubuntu-ui-toolkit-plugin (18 1.3) qtdeclarative5-ubuntu-ui-toolkit-plugin-gles (2 1.3) qtdeclarative5-ubuntu-web-plugin (5 0.23+15.10.20150929-0ubuntu1) qtdeclarative5-unity-action-plugin (0 (null)) webbrowser-app-assets (0 (null)) qtdeclarative5-ubuntu-ui-extras-browser-plugin (3 0.22) qtdeclarative5-ubuntu-ui-extras-browser-plugin (3 0.22) webbrowser-app-assets (0 (null)) Provides: 0.23+15.10.20150929-0ubuntu1 - webbrowser-app-assets Reverse Provides: 

Lo mismo para unity-tweak-tool

 % apt-cache showpkg unity-tweak-tool Package: unity-tweak-tool Versions: 0.0.6ubuntu3 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_universe_binary-i386_Packages) Description Language: File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_universe_binary-i386_Packages MD5: 03fe374b7c5423fb415fda866ee7d016 Description Language: en File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_universe_i18n_Translation-en MD5: 03fe374b7c5423fb415fda866ee7d016 Reverse Depends: Dependencies: 0.0.6ubuntu3 - python3 (0 (null)) python3:any (2 3.3.2-2~) gir1.2-glib-2.0 (0 (null)) gir1.2-gtk-3.0 (0 (null)) unity (2 6.8) python3-xdg (0 (null)) python3-cairo (0 (null)) dconf-gsettings-backend (16 (null)) gsettings-backend (0 (null)) Provides: 0.0.6ubuntu3 - Reverse Provides: 

Y webapps-common , quiere decir unity-webapps-common tiene las siguientes dependencias

 % apt-cache showpkg unity-webapps-common Package: unity-webapps-common Versions: 2.4.17+15.10.20150616-0ubuntu1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_binary-i386_Packages) (/var/lib/dpkg/status) Description Language: File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_binary-i386_Packages MD5: 6239cf9f51a5f55b69feac74e29c76c0 Description Language: en File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_wily_main_i18n_Translation-en MD5: 6239cf9f51a5f55b69feac74e29c76c0 Reverse Depends: unity-webapps-youtube,unity-webapps-common unity-webapps-yandexnews,unity-webapps-common unity-webapps-yandexmusic,unity-webapps-common unity-webapps-yandexmail,unity-webapps-common unity-webapps-yandex-music,unity-webapps-common unity-webapps-yahoonews,unity-webapps-common unity-webapps-yahoomail,unity-webapps-common unity-webapps-wordpress-com,unity-webapps-common unity-webapps-wordpress,unity-webapps-common unity-webapps-vkcom,unity-webapps-common unity-webapps-twitter,unity-webapps-common unity-webapps-tumblr,unity-webapps-common unity-webapps-reddit,unity-webapps-common unity-webapps-qq-mail,unity-webapps-common unity-webapps-pandora,unity-webapps-common unity-webapps-newsblur,unity-webapps-common unity-webapps-mail-ru,unity-webapps-common unity-webapps-livemail,unity-webapps-common unity-webapps-linkedin,unity-webapps-common unity-webapps-librefm,unity-webapps-common unity-webapps-launchpad,unity-webapps-common unity-webapps-lastfm-radio,unity-webapps-common unity-webapps-hulu-player,unity-webapps-common unity-webapps-grooveshark,unity-webapps-common unity-webapps-googleplusgames,unity-webapps-common unity-webapps-googleplus,unity-webapps-common unity-webapps-googlenews,unity-webapps-common unity-webapps-googledocs,unity-webapps-common unity-webapps-googlecalendar,unity-webapps-common unity-webapps-gmail,unity-webapps-common 2.4.17+14.04.20140122-0ubuntu1 unity-webapps-facebookmessenger,unity-webapps-common unity-webapps-deviantart,unity-webapps-common unity-webapps-dev,unity-webapps-common 2.4.16 unity-webapps-dev,unity-webapps-common unity-webapps-deezer,unity-webapps-common unity-webapps-cnn-news,unity-webapps-common unity-webapps-bbcnews,unity-webapps-common unity-webapps-amazoncloudreader,unity-webapps-common ubuntukylin-desktop,unity-webapps-common unity-asset-pool,unity-webapps-common 2.4.13-0ubuntu1 unity-asset-pool,unity-webapps-common 2.4.13-0ubuntu1 ubuntu-desktop,unity-webapps-common Dependencies: 2.4.17+15.10.20150616-0ubuntu1 - gir1.2-glib-2.0 (0 (null)) python3 (0 (null)) python3-gi (0 (null)) unity-asset-pool (4 0.8.24daily12.12.05-0ubuntu1) unity-webapps-service (2 2.3.8-0ubuntu3) xdg-utils (0 (null)) session-migration (0 (null)) xul-ext-unity (18 0.3.1) unity-chromium-extension (0 (null)) unity-webapps (0 (null)) unity-webapps-amazon (0 (null)) unity-webapps-angrybirds (0 (null)) unity-webapps-cuttherope (0 (null)) unity-webapps-facebookapps (0 (null)) unity-webapps-googlereader (0 (null)) unity-webapps-lordofultima (0 (null)) unity-webapps-pandora-com (0 (null)) unity-webapps-tiberiumalliances (0 (null)) unity-webapps (0 (null)) Provides: 2.4.17+15.10.20150616-0ubuntu1 - Reverse Provides: