cuadro de Ubuntu que vuelve a mostrar la pantalla de inicio de sesión después de la actualización

Mi caja de Ubuntu 12.04 ha estado funcionando bien. Una actualización reciente puede haber estropeado algo.

Normalmente ejecuto ventanas remotas en él, y noté que mis ventanas no se iniciaban. Luego intenté iniciar sesión directamente desde la consola GUI, y veo que después de presionar enter en la contraseña (válida), la página vuelve a aparecer. No es un error de contraseña, ya que me daría un error en línea. Veo que algunos mensajes aparecen y desaparecen rápidamente cuando la pantalla de inicio de sesión desaparece y luego se vuelve a mostrar, pero desaparecen demasiado rápido para leer.

Pude ejecutar el inicio de sesión no gui, realicé una actualización y luego reinicié, pero está haciendo lo mismo.

Tengo una conexión Samba desde mi caja de Windows, y eso sigue funcionando.

Si importa, aquí está mi salida uname (un tanto elidida):

Linux … 3.2.0-26-genérico # 41-Ubuntu SMP jue jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU / Linux

¿Qué puedo hacer para solucionar esto?

Tenga en cuenta que cuando selecciono “Sesión de invitado”, me permite iniciar sesión y muestra el administrador de ventanas. Esto me parece significativo. ¿Significa esto que algo específico a mi inicio de sesión está causando que falle?

Nota: si importa, aquí está la salida de / var / log / dmesg. La línea sobre gdm parece interesante:

[ 9.815883] Bluetooth: RFCOMM TTY layer initialized [ 9.815887] Bluetooth: RFCOMM socket layer initialized [ 9.815888] Bluetooth: RFCOMM ver 1.11 [ 9.879088] [PCSPP,TRISTATE] [ 9.879092] parport0: irq 7 detected [ 9.883935] type=1400 audit(1341871177.871:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=845 comm="apparmor_parser" [ 9.884365] type=1400 audit(1341871177.871:11): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/ntpd" pid=851 comm="apparmor_parser" [ 9.950397] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X [ 9.961160] init: gdm main process (907) killed by TERM signal [ 9.966358] lp0: using parport0 (polling). 

Otra información útil puede estar en lo que aparece en /var/log/auth.log cuando bash iniciar sesión:

 Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session closed for user lightdm Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session opened for user -username- by (uid=0) Jul 11 08:28:32 -hostname- lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0 Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session closed for user -username- Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session opened for user lightdm by (uid=0) Jul 11 08:28:32 -hostname- lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0 Jul 11 08:28:33 -hostname- lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "-username-" Jul 11 08:28:33 -hostname- dbus[769]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.60" (uid=104 pid=14858 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.16" (uid=0 pid=1329 comm="/usr/sbin/console-kit-daemon --no-daemon ") 

Ok, lo he descubierto. Fue simplemente un error en mi .bashrc. Finalmente vi mi archivo .xsession-errors. No fue un cambio reciente en mi .bashrc, pero recientemente cambié mi .profile a la fuente. Creo que el problema es que lo obtengo de la shell Bourne, por lo que algunas cosas específicas de Bash fallan.

Reseleccioné el administrador de ventanas (Gnome) en la pantalla de inicio de sesión. Eso es todo lo que se necesita para que el inicio de sesión en el trabajo para mí sin la nueva descripción que describe.

Hay una “barra” OK en la parte inferior de la lista. Después de seleccionar Gnome, hice clic en Aceptar.

Si puede, ejecute “tail -f / var / log / dmesg” desde el terminal, luego cambie a la GUI e intente iniciar sesión allí. También puede intentar ejecutar en GNOME-2d

También quizás pueda ayudar:

Ctrl + Alt + F1

  sudo dpkg-reconfigure lightdm 

(luego seleccione lightdm , ok , reiniciar)

Y si usa GNOME, simplemente intente iniciar sesión en el modo Ubuntu2d y reinstale o arregle su GNOME.

Isntall Gnome Session Fallback:

 apt-get install gnome-session-fallback 

Luego seleccione “Gnome Classic” en la pantalla de inicio de sesión (con o sin efectos).

Puede obtener los mismos síntomas, si su archivo Xauthority ( ~/.Xauthority ) está roto de alguna manera. Simplemente elimínelo / muévalo y podría estar bien:

El inicio de sesión de escritorio falla, el terminal funciona

Para mí, de alguna manera, la propiedad de los archivos .Xauthority había vuelto a root:root . Cambiar la propiedad de nuevo a mi userid solucionó el problema.