Sound Blaster Recon3D no funciona

Instalé ubuntu 12.10 en mi computadora y soy totalmente nuevo en ubuntu. No puedo hacer que mi tarjeta de sonido funcione, es un blaster de sonido recon3D. Leí que esta tarjeta ahora tiene soporte en esta versión de ubuntu (creatividad HDA). Esto es lo que sucede: a veces, cuando enciendo la computadora, no emite ningún sonido, pero Ubuntu la detecta, puedo configurar los ajustes de sonido. A veces, cuando enciendo mi PC, cada vez que se reproduce un sonido, solo puedo escuchar un ruido blanco (un ruido realmente alto) proveniente de mis altavoces y headphnoes. Intenté encontrar algo en Internet, pero solo encontré una solución que funciona para las tarjetas HDA Intel. Como trabajo, estoy usando mi audio HDMI que viene de mi tarjeta de video Nvidia (GTX570). ¡Gracias a todos!

Solución

Abre una terminal y ejecuta el siguiente comando:

echo "options snd-hda-intel position_fix=1" | sudo tee -a /etc/modprobe.d/alsa-base.conf 

Explicación

Esto agregará una nueva línea con las options snd-hda-intel position_fix=1 a /etc/modprobe.d/alsa-base.conf para que ALSA se inicialice con las opciones correctas establecidas en lugar de inicializar ALSA con opciones incompatibles, eliminando el módulo posteriormente y recargarlo con opciones compatibles como se describe en la respuesta original.

Informe de error correspondiente: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1166529


Respuesta original

¡Decir ah! Encontré una solución yo mismo. Aquí va:

Agregue estas dos líneas antes del comando “exit 0” en el archivo rc.local en el directorio / etc:

 rmmod snd_hda_intel modprobe snd_hda_intel position_fix=1 

Esto debería arreglarlo.

Intereting Posts