Instalar una versión más reciente de git en un LTS

No puedo actualizar mi lucyn lynx 10.04 LTS porque las nuevas distribuciones de ubuntu no funcionan en esa computadora. Necesito instalar un git versión 1.7.10 para la gestión de credenciales. La versión de Git es 1.7.0.4 en 10.04 LTS:

$ dpkg -l *git* +++-==============-==============-============================================ ii git-core 1:1.7.0.4-1ubu fast, scalable, distributed revision control 

¿Hay una manera o un backport para instalar git 1.7.10 o más nuevo?

El PPA ppa:git-core/ppa proporciona backports de la versión estable más actual de Git para varias versiones de Ubuntu.

En la línea de comandos puede agregar el PPA usando:

 sudo add-apt-repository ppa:git-core/ppa 

Si recibe un error que indica que no se encontró add-apt-repository , instálelo con:

 sudo apt-get install python-software-properties