Quiero instalar libssl.0.9.8

Estoy intentando instalar el progtwig utorrent, y cuando ejecuto el progtwig obtengo

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory 

Estoy navegando por los diferentes foros desde ayer y no encontré nada útil hasta ahora, así que, por favor, dime, ¿cuál es el problema?

En general, debe buscar software a través del centro de software o, si le gusta la línea de comandos, puede usar la apt-cache search . En este caso, el siguiente paquete apareció (en 11.10): libssl0.9.8

Puedes intentar instalarlo ( sudo apt-get install libssl0.9.8 ). Si esto no funciona, es posible que desee informarnos qué versión de ubuntu está utilizando.

Si está usando 11.10 (ya que no lo mencionó) entonces tiene libssl1.0.0 que es más alto que 0.9.8. Cualquier progtwig que necesite 0.9.8 también podrá manejar versiones superiores a esa.

Si NO tienes 11.10 entonces tienes varias formas:

  1. Vaya al sitio de OpenSSL: http://www.openssl.org/ y siga las instalaciones allí.

  2. Vaya a Paquetes de Ubuntu y descargue el archivo .DEB desde allí: http://packages.ubuntu.com/

  3. Vaya a Paquetes de Debian y descargue el .DEB desde allí: http://www.debian.org/distrib/packages

  4. Instálalo a través de apt-get o aptitude :

    • sudo apt-get install libssl0.9.8 – Para la versión 0.9.8
    • sudo aptitude install libssl0.9.8 – Para la versión 0.9.8
    • sudo apt-get install libssl1.0.0 – Para la versión 1.0.0
    • sudo aptitude install libssl1.0.0 – Para la versión 1.0.0

En la versión de Ubuntu 12.04 64bit, funcionó para instalar la versión de 32 bits:

 sudo apt-get install libssl0.9.8:i386 

Pero, por supuesto, cuando estás en Ubuntu de 32 bits, esto debería funcionar (sin el :i386 ):

 sudo apt-get install libssl0.9.8 

Solo intente estos pasos cuando lo necesite para CAV para Linux.

Si ya intentaste instalar cav pero hay un error con Libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Desinstale todo libssl0.9.8 de / con Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

y luego instalar la forma normal.

  1. Crear un directorio /opt/COMODO

    Copie el archivo cav allí:

     cd /opt/COMODO sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb 
  2. Descargar el controlador y reconstruir el controlador

    copiarlos a /opt/COMODO

    Ejecutar post configuración:

     sudo /opt/COMODO/post_setup.sh 
  3. Ejecute esto solo si recibe un error que indica que los módulos RedirFS no están instalados

     sudo bash /opt/COMODO/fix_rebuild_driver.sh sudo /opt/COMODO/post_setup.sh 
  4. Reiniciar

    Intereting Posts